Zapier integration returns error

  • updated
  • Fixed

I've tested the beta version of Zapier. I wanted a new post in the forum to be added to a DaPulse board. Zapier says: "Required field "Pulse Name" (pulse__name) is missing."


The first test works fine, but when I add a new topic in the forum after the test is done I get the reply above. I have used the UserEcho field "Header" to be used when creating a "Pulse name".


Any suggestions?

Pinned replies
-1
Sergey Stukov
  • Answer
  • Fixed

We have updated our Zapier APP, now Header param will works.

Sergey Stukov

It's very strange, after fix we never return fields with data__ prefix as shown on your screenshot.

Don't know how avoid this at this moment. Looks like old version of our app running in your ZAP, caching issue on Zapier side. One of the ideas is pause your current ZAP and recreate it.

vegar

Ok I'll recreate it, and do another test. I'll give you feedback hopefully during the day. Thanks.

-1
vegar

btw. do you know that now, when I create a new zapp and search for UE in Zapier, there are 2 apps appearing?

Sergey Stukov

Yes, we know. Zapier doens't allow to delete apps that have at least one user. So you need to use a new one like we pointed on the screenshot below.


vegar

I don't know why but it seems to work now. I've done a couple of tests. I'll get back to you if this problem appears again. Thanks for your quick feedback!

vegar

Hi again. Everything went fine yesterday. All posts was added to DaPulse. I did not change anything from yesterday till today. But today I got an error again. I'll send you history from yesterday and today on the same Zapp.

-1
vegar

YESTERDAY:

status__updated:
2016-09-08T08:20:20.948Z
author__is_authenticated:
true
author__email:
vegar.limstrand@compostmarketing.com
author__date_joined:
2016-06-27T11:00:09.759Z
author__language:
en
author__is_staff:
true
header:
test bugg 2
author__name:
vegar.limstrand
author__id:
1
current_user_vote:
0
id:
24
description:
<p>asdf</p>
author__last_activity:
2016-09-08T08:20:21.925Z
vote__positive:
0
private_comment_count:
0
vote__current_user:
0
category__id:
28
category__name:
Other
comment_count:
0
type__id:
15
updated:
2016-09-08T08:20:20.948Z
author__name_and_title:
vegar.limstrand
status__color:
999999
author__last_login:
2016-09-08T08:12:58.460Z
author__rating:
3.97
vote__diff:
0
vote__total:
0
type__name:
Bugs
created:
2016-09-08T08:20:20.948Z
url:
http://feedback.carmamail.com/topics/24-test-bugg-2/
status__id:
1
author__avatar_url:
/s/cache/af/77/af7713523168c01f17d756b588c89a57.png
vote__negative:
0
author__slug:
vegarlimstrand
Fields with no value:
author__title
tags

status__name

-1
vegar

TODAY:

data__type__name:
Bugs
data__author__is_staff:
false
data__header:
Purchase history - sorting on transaction date don't work
data__author__slug:
ida-maria-hogkvist
data__author__is_authenticated:
true
data__type__id:
15
data__author__name:
Ida-Maria Högkvist
data__author__last_login:
2016-09-06T08:19:59.843Z
hook:
topic.created
data__forum__name:
General
data__author__language:
en
data__category__name:
Lists, recipients and segments
data__url:
http://feedback.carmamail.com/topics/25-purchase-history-sorting-on-transaction-date-dont-work/
data__updated:
2016-09-09T07:22:10.543Z
data__author__rating:
2.18
data__status__id:
1
data__author__name_and_title:
Ida-Maria Högkvist
data__author__avatar_url:
https://secure.gravatar.com/avatar/88c6ae399a78aae0dc3f99de2ffd5a84?default=https%3A%2F%2Fcdn.userecho.com%2Fcharacters%2F73.png%3F1&s=48
data__category__id:
3
data__author__date_joined:
2016-09-06T07:43:43.880Z
data__id:
25
data__comment_count:
0
data__status__updated:
2016-09-09T07:22:10.543Z
data__forum__id:
1
data__status__color:
999999
data__description:
<p>I'm here: recipients > recipient profile > purchase history</p><p>When trying to sort the order rows by transaction date nothing happens. </p><p>T1 has asked for a jira on this.</p>
data__created:
2016-09-09T07:22:10.543Z
created:
2016-09-09T07:22:10.914Z
data__vote__negative:
0
data__author__last_activity:
2016-09-09T07:22:10.551Z
data__author__id:
10
data__vote__diff:
0
data__vote__total:
0
data__vote__positive:
0
Fields with no value:
data__tags
data__status__name

data__author__title

-1
vegar

Any updates on this? I still have problems.

-1
Sergey Stukov
Quote from vegar

Any updates on this? I still have problems.

We have requested access for detailed logging from Zapier still waiting for response from it.

At this moment we cannot reproduce error at our side and our Test integration ZAP with daPulse.

Hope that detailed logs help us to resolve issue.